summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 18:11:50 +0100
committersL1pKn072022-03-13 18:11:50 +0100
commitdd63595d0157d61dd1614cf31b805e2ccad8c578 (patch)
treeda1619f080922260663813cba3d82ca8e51d5acb
parent95498391dd9758961080521879bf5c7316181f77 (diff)
downloadaur-vapoursynth-plugin-ssiq-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0a7d01d559f..59659a9bc1a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 19:59:27 UTC 2019
pkgbase = vapoursynth-plugin-ssiq-git
pkgdesc = Plugin for Vapoursynth: ssiq (GIT version)
- pkgver = v1.0.1.g30b3a47
+ pkgver = 1.0.1.g30b3a47
pkgrel = 1
url = https://github.com/dubhater/vapoursynth-ssiq
arch = x86_64
@@ -11,8 +9,8 @@ pkgbase = vapoursynth-plugin-ssiq-git
depends = vapoursynth
provides = vapoursynth-plugin-ssiq
conflicts = vapoursynth-plugin-ssiq
+ options = debug
source = ssiq::git+https://github.com/dubhater/vapoursynth-ssiq.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-ssiq-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 86ae5d756c3e..164feacb2a02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=ssiq
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.1.g30b3a47
+pkgver=1.0.1.g30b3a47
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,21 +14,22 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
+ cd "${srcdir}/build"
../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth