summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-02-28 14:26:06 +0100
committerGustavo Alvarez2016-02-28 14:26:06 +0100
commit98abbb882ef98efe02e7fa92c63ad894cccace08 (patch)
tree5fae50c87e31e16b6494c80a7b42cf15a4c1c5aa
downloadaur-98abbb882ef98efe02e7fa92c63ad894cccace08.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b964f459a1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Feb 28 13:26:06 UTC 2016
+pkgbase = vapoursynth-plugin-svpflow2-bin
+ pkgdesc = Plugin for Vapoursynth: svpflow2-bin
+ pkgver = 4.0.0.128
+ pkgrel = 1
+ url = https://www.svp-team.com/wiki/Plugins:_SVPflow
+ arch = i686
+ arch = x86_64
+ license = custom:svp-team
+ makedepends = chrpath
+ depends = qt5-base
+ source = http://www.svp-team.com/files/gpl/svpflow-4.0.0.128.zip
+ sha1sums = fce68904ebeb5dd553673f2e936b1420e1ab7dd7
+
+pkgname = vapoursynth-plugin-svpflow2-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71b96fd76f58
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!averagehist.py
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5eb04b5f5f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=svpflow2-bin
+pkgname=vapoursynth-plugin-${_plug}
+pkgver=4.0.0.128
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('i686' 'x86_64')
+url='https://www.svp-team.com/wiki/Plugins:_SVPflow'
+license=('custom:svp-team')
+depends=('qt5-base')
+makedepends=('chrpath')
+source=("http://www.svp-team.com/files/gpl/svpflow-${pkgver}.zip")
+sha1sums=('fce68904ebeb5dd553673f2e936b1420e1ab7dd7')
+
+package(){
+ cd "svpflow-${pkgver}/lib-linux/vapoursynth"
+ [ "${CARCH}" = "i686" ] && install -Dm755 x32/libsvpflow2_vs.so "${pkgdir}/usr/lib/vapoursynth/libsvpflow2.so"
+ [ "${CARCH}" = "x86_64" ] && install -Dm755 x64/libsvpflow2_vs64.so "${pkgdir}/usr/lib/vapoursynth/libsvpflow2.so"
+
+ chrpath -d "${pkgdir}/usr/lib/vapoursynth/libsvpflow2.so"
+}