summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-10-12 16:51:07 +0200
committersL1pKn072019-10-12 16:51:07 +0200
commit7d28012dd13f9e54549202ce71c17c26e1e0fa74 (patch)
treeef47b347ff9efc6b3c20d38b6740fa572cb260d1
downloadaur-7d28012dd13f9e54549202ce71c17c26e1e0fa74.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d94ad0c876b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-tbilateral-git
+ pkgdesc = Plugin for Vapoursynth: tbilateral (Fork)(GIT version)
+ pkgver = v2.0.g2796911
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-tbilateral
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-tbilateral
+ conflicts = vapoursynth-plugin-tbilateral
+ source = tbilateral::git+https://github.com/dubhater/vapoursynth-tbilateral.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-tbilateral-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a486e079c94c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=tbilateral
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v2.0.g2796911
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (Fork)(GIT version)"
+arch=('x86_64')
+url='https://github.com/dubhater/vapoursynth-tbilateral'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-tbilateral.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}