summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-08-26 10:55:09 +0200
committerGustavo Alvarez2016-08-26 10:55:09 +0200
commit3c60ddf08e39eecca050d17e6d95606dee5ed5ad (patch)
tree51736876b56cfebafef97e13f7952cd85cc9b0e3
parentf9c8bbd75cd646159297e9c2a79d31d7fa729f5c (diff)
downloadaur-3c60ddf08e39eecca050d17e6d95606dee5ed5ad.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e702214d8b5..1b0735be3c29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:08:17 UTC 2015
+# Fri Aug 26 08:55:04 UTC 2016
pkgbase = vapoursynth-plugin-tcanny-git
pkgdesc = Plugin for Vapoursynth: tcanny (GIT version)
- pkgver = r2.7.g2ee6ee9
+ pkgver = r7.0.g5e48ea1
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171136
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index e7e11e448534..1fd5e5a892c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=tcanny
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r2.7.g2ee6ee9
+pkgver=r7.0.g5e48ea1
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -20,16 +20,21 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
build() {
cd "${_plug}"
- ./configure --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
make
}
package(){
cd "${_plug}"
- make install
+ make DESTDIR="${pkgdir}" install
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}