summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:37:31 +0200
committersl1pkn072015-06-08 20:37:31 +0200
commit9e2e70db08f92e5ac6b3eedc9a8f0f103ea3f56e (patch)
tree960ff30e56c24c2540e05c52a1540bca833c6f70
downloadaur-9e2e70db08f92e5ac6b3eedc9a8f0f103ea3f56e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6586efbf24d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-tcanny-git
+ pkgdesc = Plugin for Vapoursynth: tcanny (GIT version)
+ pkgver = r2.1.g0861e87
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171136
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-tcanny
+ conflicts = vapoursynth-plugin-tcanny
+ source = tcanny::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TCanny.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-tcanny-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6120a9a15e1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=tcanny
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2.1.g0861e87
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171136"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TCanny.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}