summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:59:56 +0100
committersL1pKn072019-03-02 20:59:56 +0100
commit185b43c1caae01e1dffbbad6bd1e34d414125a2e (patch)
treea41e150ee27542c6a585ad90a010108179d3c394
parent850f4368fc07cdf2c06d6aab3a1ffdd03f5a9858 (diff)
downloadaur-185b43c1caae01e1dffbbad6bd1e34d414125a2e.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73262ceb9838..e826b6a63f4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Feb 17 13:50:11 UTC 2017
+# Sat Mar 2 19:59:56 UTC 2019
pkgbase = vapoursynth-plugin-tcomb-git
pkgdesc = Plugin for Vapoursynth: tcomb (GIT version)
pkgver = v3.0.g48108a0
pkgrel = 1
- url = http://forum.doom9.org/showthread.php?t=171124
- arch = i686
+ url = https://forum.doom9.org/showthread.php?t=171124
arch = x86_64
license = GPL2
makedepends = git
@@ -13,7 +12,7 @@ pkgbase = vapoursynth-plugin-tcomb-git
provides = vapoursynth-plugin-tcomb
conflicts = vapoursynth-plugin-tcomb
source = tcomb::git+https://github.com/dubhater/vapoursynth-tcomb.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-tcomb-git
diff --git a/PKGBUILD b/PKGBUILD
index 0271ac290fa2..8c78db6f2f86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=v3.0.g48108a0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
-url='http://forum.doom9.org/showthread.php?t=171124'
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=171124'
license=('GPL2')
depends=('vapoursynth')
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -21,20 +21,23 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
+
make
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}