summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:37:13 +0200
committerGustavo Alvarez2016-10-19 22:37:13 +0200
commit33b5e7fb45fa60ce303c5c138253b8398610ded2 (patch)
treeb2c73fa6daf9bd4c3746a7a92beec838e7e00a62
parent8ca856fd44a17925343319d5121d7dab44c073c2 (diff)
downloadaur-33b5e7fb45fa60ce303c5c138253b8398610ded2.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e82f506c9295..a4259412fae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:38:54 UTC 2015
+# Wed Oct 19 20:37:00 UTC 2016
pkgbase = vapoursynth-plugin-templinearapproximate-git
pkgdesc = Plugin for Vapoursynth: templinearapproximate (GIT version)
- pkgver = r3.3.g540e788
+ pkgver = r3.4.g50c4633
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=169782
arch = i686
@@ -13,7 +13,7 @@ pkgbase = vapoursynth-plugin-templinearapproximate-git
provides = vapoursynth-plugin-templinearapproximate
conflicts = vapoursynth-plugin-templinearapproximate
source = templinearapproximate::git+https://bitbucket.org/mystery_keeper/templinearapproximate-vapoursynth.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-templinearapproximate-git
diff --git a/PKGBUILD b/PKGBUILD
index ae4d1f55c36a..45fab7b72f2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=templinearapproximate
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r3.3.g540e788
+pkgver=r3.4.g50c4633
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -13,9 +13,9 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://bitbucket.org/mystery_keeper/${_plug}-vapoursynth.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -38,7 +38,10 @@ build() {
package(){
cd "${_plug}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 MCDenoise.py "${pkgdir}${_sites_packages}/MCDenoise.py"
+ install -Dm644 MCDenoise.py "${pkgdir}${_site_packages}/MCDenoise.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/MCDenoise.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/MCDenoise.py"
+
install -Dm644 TempLinearApproximate-readme.txt "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.txt"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}