summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 21:00:06 +0100
committersL1pKn072019-03-02 21:00:06 +0100
commita997ef6f6fe9f1bce30b48349a1fe5e78b44995f (patch)
treefc5a98d54cb88c961e5ad0b7d8c6a9cf8451d2cb
parent33b5e7fb45fa60ce303c5c138253b8398610ded2 (diff)
downloadaur-a997ef6f6fe9f1bce30b48349a1fe5e78b44995f.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4259412fae7..c27c7a4f3bc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 20:37:00 UTC 2016
+# Sat Mar 2 20:00:06 UTC 2019
pkgbase = vapoursynth-plugin-templinearapproximate-git
pkgdesc = Plugin for Vapoursynth: templinearapproximate (GIT version)
- pkgver = r3.4.g50c4633
+ pkgver = r3.6.g604688d
pkgrel = 1
- url = http://forum.doom9.org/showthread.php?t=169782
- arch = i686
+ url = https://forum.doom9.org/showthread.php?t=169782
arch = x86_64
license = MIT
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 45fab7b72f2c..82d94897e9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_plug=templinearapproximate
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r3.4.g50c4633
+pkgver=r3.6.g604688d
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
-url='http://forum.doom9.org/showthread.php?t=169782'
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=169782'
license=('MIT')
depends=('vapoursynth')
makedepends=('git')
@@ -24,6 +24,7 @@ pkgver() {
prepare() {
cd "${_plug}"
+
echo "all:
gcc -c -fPIC ${CFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o main.o src/main.c
gcc -c -fPIC ${CFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o processplane.o src/processplane.c
@@ -31,13 +32,13 @@ prepare() {
}
build() {
- cd "${_plug}"
- make
+ make -C "${_plug}"
}
package(){
cd "${_plug}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
install -Dm644 MCDenoise.py "${pkgdir}${_site_packages}/MCDenoise.py"
python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/MCDenoise.py"
python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/MCDenoise.py"