summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-25 17:08:42 +0200
committersl1pkn072015-09-25 17:08:42 +0200
commitcd1dc4234d3aff77cfadd0e6a291698f2c1bfbcc (patch)
tree14fa1630c2a4c37a9405322cb489f7a4645a903c
parent004884595b374821386203cda4ec52501381ca58 (diff)
downloadaur-cd1dc4234d3aff77cfadd0e6a291698f2c1bfbcc.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74f44666e920..34f54db438b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = vapoursynth-plugin-templinearapproximate-git
provides = vapoursynth-plugin-templinearapproximate
conflicts = vapoursynth-plugin-templinearapproximate
source = templinearapproximate::git+https://bitbucket.org/mystery_keeper/templinearapproximate-vapoursynth.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = vapoursynth-plugin-templinearapproximate-git
diff --git a/PKGBUILD b/PKGBUILD
index 4352920ecb13..acfe112e65ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,37 +6,34 @@ pkgver=r3.3.g540e788
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?t=169782"
+url='http://forum.doom9.org/showthread.php?t=169782'
license=('MIT')
depends=('vapoursynth')
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://bitbucket.org/mystery_keeper/${_plug}-vapoursynth.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
+
_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
prepare() {
- cd "${_gitname}"
echo "all:
- gcc -shared ${CFLAGS} -fPIC -o "lib${_plug}.so" src/main.c src/processplane.c $(pkg-config --cflags vapoursynth)" > Makefile
+ gcc -o lib${_plug}.so ${CFLAGS} ${LDFLAGS} $(pkg-config --cflags vapoursynth) -fPIC -shared ${_plug}/src/main.c ${_plug}/src/processplane.c" > Makefile
}
build() {
- cd "${_gitname}"
make
}
package(){
- cd "${_gitname}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 MCDenoise.py "${pkgdir}${_sites_packages}/MCDenoise.py"
- install -Dm644 TempLinearApproximate-readme.txt "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${_plug}/MCDenoise.py" "${pkgdir}${_sites_packages}/MCDenoise.py"
+ install -Dm644 "${_plug}/TempLinearApproximate-readme.txt" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}