summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-10-19 17:20:43 +0200
committersL1pKn072022-10-19 17:20:43 +0200
commit28e64ac5cb5833c6038d9fa3eef5e5a40e49d9c8 (patch)
tree8aab00455f9d544ceb3a172615dd16090c6e3402
parentd4b955ac91062f91073fe44e9ca99975b95349e0 (diff)
downloadaur-28e64ac5cb5833c6038d9fa3eef5e5a40e49d9c8.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddd2bc5b534c..401fb7dcd395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-timecube-git
pkgdesc = Plugin for Vapoursynth: timecube (GIT version)
- pkgver = 3.1.0.g22acabc
+ pkgver = 3.1.8.g868ed49
pkgrel = 1
url = https://github.com/sekrit-twc/timecube
arch = x86_64
@@ -12,6 +12,8 @@ pkgbase = vapoursynth-plugin-timecube-git
options = debug
source = timecube::git+https://github.com/sekrit-twc/timecube.git
source = git+https://github.com/sekrit-twc/vsxx.git
+ source = git+https://github.com/sekrit-twc/graphengine.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ad69ab007b2a..60652e68aab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_plug=timecube
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=3.1.0.g22acabc
+pkgver=3.1.8.g868ed49
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,11 +14,13 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/sekrit-twc/${_plug}.git"
+source=("${_plug}::git+https://github.com/sekrit-twc/timecube.git"
'git+https://github.com/sekrit-twc/vsxx.git'
+ 'git+https://github.com/sekrit-twc/graphengine.git'
)
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
)
options=('debug')
@@ -29,22 +31,23 @@ pkgver() {
prepare() {
cd "${_plug}"
- git config submodule.vsplugin/vsxx.url "${srcdir}/vsxx"
- git submodule update --init
+ git config submodule.vsxx.url "${srcdir}/vsxx"
+ git config submodule.graphengine.url "${srcdir}/graphengine"
+ git -c protocol.file.allow=always submodule update --init \
+ vsxx \
+ graphengine
# use system vapoursynth headers
- rm -fr vsxx/VapourSynth.h
- rm -fr vsxx/VSScript.h
- rm -fr vsxx/VSHelper.h
+ rm -fr vsxx/vapoursynth
- sed -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
- -e 's|"VSHelper.h"|<VSHelper.h>|g' \
- -i vsxx/VapourSynth++.hpp
+ sed -e 's|"VapourSynth4.h"|<VapourSynth4.h>|g' \
+ -i vsxx/VapourSynth4++.hpp
- sed -e "s|-Ivsxx|& $(pkg-config --cflags vapoursynth)|g" \
- -e '/VSScript.h/d' \
+ sed -e "s|-Ivsxx/vapoursynth|$(pkg-config --cflags vapoursynth)|g" \
+ -e '/VSConstants4/d' \
+ -e '/VapourSynth4.h/d' \
-e '/VapourSynth.h/d' \
- -e '/VSHelper.h/d'\
+ -e '/VSHelper4.h/d'\
-i Makefile
}