summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 17:30:54 +0100
committersL1pKn072023-01-23 17:30:54 +0100
commitd5e63e9f44815d8b55d1f69970e88374ad14fcf7 (patch)
treed1dfa82608aaff42a8e26f24601f308557f4e3b5
parent28e64ac5cb5833c6038d9fa3eef5e5a40e49d9c8 (diff)
downloadaur-d5e63e9f44815d8b55d1f69970e88374ad14fcf7.tar.gz
bump
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60652e68aab4..c51dce75377d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,10 +40,7 @@ prepare() {
# use system vapoursynth headers
rm -fr vsxx/vapoursynth
- sed -e 's|"VapourSynth4.h"|<VapourSynth4.h>|g' \
- -i vsxx/VapourSynth4++.hpp
-
- sed -e "s|-Ivsxx/vapoursynth|$(pkg-config --cflags vapoursynth)|g" \
+ sed -e "s| -Ivsxx/vapoursynth||g" \
-e '/VSConstants4/d' \
-e '/VapourSynth4.h/d' \
-e '/VapourSynth.h/d' \
@@ -52,11 +49,14 @@ prepare() {
}
build() {
+ CPPFLAGS+=" $(pkg-config --cflags vapoursynth)"
+
make -C "${_plug}" X86=1
}
package(){
install -Dm755 "${_plug}/vscube.so" "${pkgdir}/usr/lib/vapoursynth/libvscube.so"
+
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}