summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 19:42:05 +0100
committersL1pKn072019-02-08 19:42:05 +0100
commitdca2f36591ca8cae92b7f66389f608f5747342e8 (patch)
tree48f5d624e93859b8760d65691daaa0ffd3aababa
downloadaur-dca2f36591ca8cae92b7f66389f608f5747342e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..718a69aa4aa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Feb 8 18:42:05 UTC 2019
+pkgbase = vapoursynth-plugin-timecube-git
+ pkgdesc = Plugin for Vapoursynth: timecube
+ pkgver = r2a.0.gd3982b2
+ pkgrel = 1
+ url = https://github.com/sekrit-twc/timecube
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-timecube
+ conflicts = vapoursynth-plugin-timecube
+ source = timecube::git+https://github.com/sekrit-twc/timecube.git
+ source = git+https://github.com/sekrit-twc/vsxx.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-timecube-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23a219a1435e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Mikuro Kagamine <mikurok@forgecrushing.com>
+
+_plug=timecube
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2a.0.gd3982b2
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('x86_64')
+url='https://github.com/sekrit-twc/timecube'
+license=('GPL2')
+depends=('vapoursynth'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/sekrit-twc/${_plug}.git"
+ 'git+https://github.com/sekrit-twc/vsxx.git'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ )
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ git config submodule.vsplugin/vsxx.url "${srcdir}/vsxx"
+ git submodule update --init
+
+ # use system vapoursynth headers
+ rm -fr vsxx/VapourSynth.h
+ rm -fr vsxx/VSScript.h
+ rm -fr vsxx/VSHelper.h
+
+ sed -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
+ -e 's|"VSHelper.h"|<VSHelper.h>|g' \
+ -i vsxx/VapourSynth++.hpp
+
+ sed -e "s|-Ivsxx|& $(pkg-config --cflags vapoursynth)|g" \
+ -e '/VSScript.h/d' \
+ -e '/VapourSynth.h/d' \
+ -e '/VSHelper.h/d'\
+ -i Makefile
+}
+
+build() {
+ make -C "${_plug}" X86=1
+}
+
+package(){
+ install -Dm755 "${_plug}/vscube.so" "${pkgdir}/usr/lib/vapoursynth/libvscube.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}
+