summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Holmer2020-03-03 20:19:14 -0500
committerJosh Holmer2020-03-03 20:19:14 -0500
commit1531586265d2b2afed311a8a26b6fb5bfd7502b3 (patch)
treedb924695cd31dde7dcd8e1108639d1dad82e8a26
downloadaur-1531586265d2b2afed311a8a26b6fb5bfd7502b3.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eeac4201326d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-tonemap-git
+ pkgdesc = Plugin for Vapoursynth: tonemap (GIT version)
+ pkgver = r6.5a037ae
+ pkgrel = 1
+ url = https://github.com/ifb/vapoursynth-tonemap
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-tonemap
+ conflicts = vapoursynth-plugin-tonemap
+ source = tonemap::git+https://github.com/ifb/vapoursynth-tonemap.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-tonemap-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6d78eab2f70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Joshua Holmer <jholmer.in@gmail.com>
+
+_plug=tonemap
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r6.5a037ae
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/ifb/vapoursynth-tonemap'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/ifb/vapoursynth-tonemap.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package() {
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}