summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-03-30 16:28:09 +0200
committersL1pKn072018-03-30 16:28:09 +0200
commit6202a5c59006718399ee36683e6c2c9baef996a1 (patch)
tree106e602ba3bb69b08245885aeb8623f8180378ac
downloadaur-6202a5c59006718399ee36683e6c2c9baef996a1.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4abcb1e6225
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Mar 30 14:28:08 UTC 2018
+pkgbase = vapoursynth-plugin-ttempsmooth-git
+ pkgdesc = Plugin for Vapoursynth: ttempsmooth (GIT version)
+ pkgver = r1.2.g9e44188
+ pkgrel = 1
+ url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TTempSmooth
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-ttempsmooth
+ conflicts = vapoursynth-plugin-ttempsmooth
+ source = ttempsmooth::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TTempSmooth.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-ttempsmooth-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e92be6df53ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=ttempsmooth
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.2.g9e44188
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TTempSmooth'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TTempSmooth.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}