summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 21:00:36 +0100
committersL1pKn072019-03-02 21:00:36 +0100
commit82edfbae99e2f6c9bf71937a5b8b51e8cae22d36 (patch)
treebedf7a9f8cf3c7a363615a26d35b4393e81a2478
parenta802a576dc1b906adde6a8c24716dfdd6e743657 (diff)
downloadaur-82edfbae99e2f6c9bf71937a5b8b51e8cae22d36.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5563b3ac23b2..5107d23de46d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 30 14:30:09 UTC 2018
+# Sat Mar 2 20:00:35 UTC 2019
pkgbase = vapoursynth-plugin-ttempsmooth-git
pkgdesc = Plugin for Vapoursynth: ttempsmooth (GIT version)
- pkgver = r1.2.g9e44188
+ pkgver = r3.1.0.g67df78f
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=175351
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = vapoursynth-plugin-ttempsmooth-git
provides = vapoursynth-plugin-ttempsmooth
conflicts = vapoursynth-plugin-ttempsmooth
source = ttempsmooth::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TTempSmooth.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-ttempsmooth-git
diff --git a/PKGBUILD b/PKGBUILD
index 3847441b9c7b..6f62e967e208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=ttempsmooth
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r1.2.g9e44188
+pkgver=r3.1.0.g67df78f
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -13,7 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-TTempSmooth.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -21,13 +21,15 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
@@ -35,7 +37,7 @@ build() {
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}