summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:39:48 +0200
committerGustavo Alvarez2016-10-19 22:39:48 +0200
commit391f297cc60e7347f2843d360cb79e121ba2e56c (patch)
tree587a83ab718c6842df3ebfbff4340fd4b69f156d
parent5608e9910de34534b67aaa24c3fa1c51f42e0a6b (diff)
downloadaur-391f297cc60e7347f2843d360cb79e121ba2e56c.tar.gz
bump
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e36d83e34cf8..b14a8297b084 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:29:42 UTC 2015
+# Wed Oct 19 20:39:44 UTC 2016
pkgbase = vapoursynth-plugin-vautodeint-git
pkgdesc = Plugin for Vapoursynth: vautodeint (GIT version)
pkgver = v0.0.1.0.g70bcc3d
diff --git a/PKGBUILD b/PKGBUILD
index 5f9bc2c2f577..8030e6e95b7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/gnaggnoyil/VAutoDeint.git")
sha1sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -42,6 +42,8 @@ build() {
package(){
cd "${_plug}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 VAutoDeint.py "${pkgdir}${_sites_packages}/VAutoDeint.py"
+ install -Dm644 VAutoDeint.py "${pkgdir}${_site_packages}/VAutoDeint.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/VAutoDeint.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/VAutoDeint.py"
install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}