summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-10-11 13:35:39 +0200
committersl1pkn072015-10-11 13:35:39 +0200
commit8e9f647dd4b7cf73e1cb95998319b1736010899b (patch)
treec69fb7d3f17016f0db6b6d2a6393ccce9382e852
downloadaur-8e9f647dd4b7cf73e1cb95998319b1736010899b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba395bb34acb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-vautodeint-git
+ pkgdesc = Plugin for Vapoursynth: vautodeint (GIT version)
+ pkgver = v0.0.1.0.g70bcc3d
+ pkgrel = 1
+ url = https://github.com/gnaggnoyil/VAutoDeint
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-vautodeint
+ conflicts = vapoursynth-plugin-vautodeint
+ source = vautodeint::git+https://github.com/gnaggnoyil/VAutoDeint.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-vautodeint-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab5982f7fcbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vautodeint
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v0.0.1.0.g70bcc3d
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/gnaggnoyil/VAutoDeint'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/gnaggnoyil/VAutoDeint.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ rm -fr externalfilters/VSHelper.h externalfilters/VapourSynth.h
+
+ echo "all:
+ gcc -c -Os -g0 -std=gnu++11 -I. -fPIC -Wextra -Wno-unused-parameter ${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth) -o IsCombedTIVTCport.o externalfilters/IsCombedTIVTCport.cpp
+ gcc -c -Os -g0 -std=gnu++11 -I. -fPIC -Wextra -Wno-unused-parameter ${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth) -o PlaneDifferenceFromPrevious.o externalfilters/PlaneDifferenceFromPrevious.cpp
+ gcc -c -Os -g0 -std=gnu++11 -I. -fPIC -Wextra -Wno-unused-parameter ${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth) -o PluginInit.o externalfilters/PluginInit.cpp
+ gcc -shared -fPIC ${LDFLAGS} -o lib${_plug}.so IsCombedTIVTCport.o PlaneDifferenceFromPrevious.o PluginInit.o" > Makefile
+}
+
+build() {
+ cd "${_plug}"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 VAutoDeint.py "${pkgdir}${_sites_packages}/VAutoDeint.py"
+ install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}