summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 21:00:46 +0100
committersL1pKn072019-03-02 21:00:46 +0100
commit9fa626e844ccd0244b7008ee26d6fcf4a1d8dd12 (patch)
treead726dd3d8a69644daa31a81d64e32a51f2e1516
parent5ae4c5d415caab53e54b56a72a069becaae1761d (diff)
downloadaur-9fa626e844ccd0244b7008ee26d6fcf4a1d8dd12.tar.gz
bump
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 325b194dec31..59a7fc3151de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 20:40:53 UTC 2016
+# Sat Mar 2 20:00:46 UTC 2019
pkgbase = vapoursynth-plugin-vautodeint-git
pkgdesc = Plugin for Vapoursynth: vautodeint (GIT version)
pkgver = v0.0.1.0.g70bcc3d
pkgrel = 1
url = https://github.com/gnaggnoyil/VAutoDeint
- arch = i686
arch = x86_64
license = GPL
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 510441da9998..6fadd77f542b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=v0.0.1.0.g70bcc3d
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/gnaggnoyil/VAutoDeint'
license=('GPL')
depends=('vapoursynth')
@@ -23,27 +23,28 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
+ cd "${_plug}/externalfilters"
- rm -fr externalfilters/VSHelper.h externalfilters/VapourSynth.h
+ rm -fr VapourSynth.h VSHelper.h
echo "all:
- g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o IsCombedTIVTCport.o externalfilters/IsCombedTIVTCport.cpp
- g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o PlaneDifferenceFromPrevious.o externalfilters/PlaneDifferenceFromPrevious.cpp
- g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o PluginInit.o externalfilters/PluginInit.cpp
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o IsCombedTIVTCport.o IsCombedTIVTCport.cpp
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o PlaneDifferenceFromPrevious.o PlaneDifferenceFromPrevious.cpp
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o PluginInit.o PluginInit.cpp
g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so *.o" > Makefile
}
build() {
- cd "${_plug}"
- make
+ make -C "${_plug}/externalfilters"
}
package(){
cd "${_plug}"
- install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm755 "externalfilters/lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
install -Dm644 VAutoDeint.py "${pkgdir}${_site_packages}/VAutoDeint.py"
python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/VAutoDeint.py"
python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/VAutoDeint.py"
+
install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}