summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-08-17 20:51:20 +0200
committerGustavo Alvarez2016-08-17 20:51:20 +0200
commit70d735ba0c0b3521cd307240e8f8ec879eacf6ed (patch)
treea99f289a794edbcb31ca6992c227855cfff39873
downloadaur-70d735ba0c0b3521cd307240e8f8ec879eacf6ed.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38f9f298cc42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Aug 17 18:51:20 UTC 2016
+pkgbase = vapoursynth-plugin-vcfreq
+ pkgdesc = Plugin for Vapoursynth: vcfreq
+ pkgver = 20160216
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=172594
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = vapoursynth
+ depends = fftw
+ source = vcfreq-20160216.7z::https://dl.dropboxusercontent.com/u/73468194/vcfreq_src_x64.7z
+ sha1sums = 68ad40a5c3775b6bd848f75094524d248b736514
+
+pkgname = vapoursynth-plugin-vcfreq
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e95d96dcf5bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vcfreq
+pkgname=vapoursynth-plugin-${_plug}
+pkgver=20160216
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=172594'
+license=('GPL')
+depends=('vapoursynth'
+ 'fftw'
+ )
+#source=("${_plug}-${pkgver}.7z::http://www.avisynth.nl/users/vcmohan/${_plug}/${_plug}_src.7z")
+source=("${_plug}-${pkgver}.7z::https://dl.dropboxusercontent.com/u/73468194/vcfreq_src_x64.7z")
+sha1sums=('68ad40a5c3775b6bd848f75094524d248b736514')
+
+prepare(){
+ rm -fr VSHelper.h VapourSynth.h
+
+ sed -e 's|"vapoursynth.h"|<VapourSynth.h>|g' \
+ -e 's|"VSHelper.h"|<VSHelper.h>|g' \
+ -e 's|vshelper|VSHelper|g' \
+ -e 's|FQSharpHelper|FQSharphelper|g' \
+ -i *
+
+ echo "all:
+ g++ -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o vcfreq.o vcfreq.cpp
+ g++ -shared -fPIC ${LDFLAGS} -L $(pkg-config --libs fftw3) -o lib${_plug}.so vcfreq.o" > Makefile
+}
+
+build() {
+ make
+}
+
+package() {
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+}