summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-08-29 01:11:59 +0200
committersL1pKn072021-08-29 01:11:59 +0200
commit6753b09ad47a544fe283ba9044f31e49a82e68fd (patch)
tree704d6de0509b6df954d7cfc76d9a3d9b150087e2
parent2460f5d11ee67809e0b53ad0293d57e5b1e8810c (diff)
downloadaur-6753b09ad47a544fe283ba9044f31e49a82e68fd.tar.gz
bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 629366853f99..0e0d6b637f22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 20:01:06 UTC 2019
pkgbase = vapoursynth-plugin-vctrans
pkgdesc = Plugin for Vapoursynth: vctrans
- pkgver = 20150910
+ pkgver = 20210717
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=172594
arch = x86_64
license = GPL
depends = vapoursynth
- source = vctrans-20150910.7z::http://www.avisynth.nl/users/vcmohan/vctrans/vctrans_src.7z
- sha256sums = 35b55c4962b9f2b48ba18ac1333dcc36064eea61ab05479a3c268f5aa66c99e7
+ source = vctrans-20210717.7z::http://www.avisynth.nl/users/vcmohan/vctrans/vctrans_src.7z
+ source = vctrans_doc-20210717.7z::http://www.avisynth.nl/users/vcmohan/vctrans/vctrans.7z
+ sha256sums = 631ebb3a2071b48f53d10ce8f3f5a1a830fe141d265eb559699cc7116de20e50
+ sha256sums = e152fc1f272e5da936d9639f0b486de1f28ebb5a7018ac42822fe93015a0046b
pkgname = vapoursynth-plugin-vctrans
-
diff --git a/PKGBUILD b/PKGBUILD
index 04c046325950..0cc38dd80edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,19 @@
_plug=vctrans
pkgname=vapoursynth-plugin-${_plug}
-pkgver=20150910
+pkgver=20210717
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('x86_64')
url='https://forum.doom9.org/showthread.php?t=172594'
license=('GPL')
depends=('vapoursynth')
-source=("${_plug}-${pkgver}.7z::http://www.avisynth.nl/users/vcmohan/${_plug}/${_plug}_src.7z")
-sha256sums=('35b55c4962b9f2b48ba18ac1333dcc36064eea61ab05479a3c268f5aa66c99e7')
+source=("${_plug}-${pkgver}.7z::http://www.avisynth.nl/users/vcmohan/${_plug}/${_plug}_src.7z"
+ "${_plug}_doc-${pkgver}.7z::http://www.avisynth.nl/users/vcmohan/${_plug}/${_plug}.7z"
+ )
+sha256sums=('631ebb3a2071b48f53d10ce8f3f5a1a830fe141d265eb559699cc7116de20e50'
+ 'e152fc1f272e5da936d9639f0b486de1f28ebb5a7018ac42822fe93015a0046b'
+ )
prepare(){
rm -fr VSHelper.h VapourSynth.h
@@ -19,7 +23,7 @@ prepare(){
-e 's|vshelper.h|VSHelper.h|g' \
-e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
-e 's|"VSHelper.h"|<VSHelper.h>|g' \
- -i *
+ -i *.{cpp,h}
echo "all:
g++ -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o vctrans.o vctrans.cpp
@@ -32,5 +36,7 @@ build() {
package() {
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 vctrans.html "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/vctrans.html"
+ for i in *.html; do
+ install -Dm644 "$i" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/$i"
+ done
}