summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-08-12 15:01:03 +0200
committersL1pKn072017-08-12 15:01:03 +0200
commit018ecaa49f950a7a918543395f00c8d3bf6a7f91 (patch)
treec9252d5940a95db905b74a2b79d029cb702929f0
parentc464a51e0f446cc6c9f2d759e63b727bd10879f7 (diff)
downloadaur-018ecaa49f950a7a918543395f00c8d3bf6a7f91.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b994e14a4d8d..7f10612a53a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Wed Jul 12 23:56:40 UTC 2017
+# Sat Aug 12 13:00:57 UTC 2017
pkgbase = vapoursynth-plugin-vfrtocfr-git
pkgdesc = Plugin for Vapoursynth: vfrtocfr
- pkgver = v1.0.2.gc25cce8
+ pkgver = v1.0.6.g6c8cd2b
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=174711
arch = i686
arch = x86_64
license = BSD
+ makedepends = meson
depends = vapoursynth
source = vfrtocfr::git+https://github.com/blaze077/Vapoursynth-VFRToCFR.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d67e7460470a..97c6d09d4bee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
_plug=vfrtocfr
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.2.gc25cce8
+pkgver=v1.0.6.g6c8cd2b
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('i686' 'x86_64')
url='https://forum.doom9.org/showthread.php?t=174711'
license=('BSD')
depends=('vapoursynth')
+makedepends=('meson')
source=("${_plug}::git+https://github.com/blaze077/Vapoursynth-VFRToCFR.git")
sha256sums=('SKIP')
@@ -18,27 +19,28 @@ pkgver() {
}
prepare(){
+ mkdir -p build
+
cd "${_plug}"
sed -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
-e 's|"VSHelper.h"|<VSHelper.h>|g' \
-i VFRToCFR.cpp
-
- echo "all:
- g++ -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o VFRToCFR.o VFRToCFR.cpp
-
- g++ -shared -L. -fPIC ${LDFLAGS} -o libvs${_plug}.so VFRToCFR.o"> Makefile
}
build() {
- cd "${_plug}"
- make
+ cd build
+ meson \
+ "../${_plug}" \
+ --prefix=/usr \
+ --buildtype=release
+
+ ninja
}
package() {
- cd "${_plug}"
- install -Dm755 "libvs${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/libvs${_plug}.so"
+ DESTDIR="${pkgdir}" ninja -C build install
- install -Dm644 README.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${pkgname}/README.rst"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${_plug}/README.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${pkgname}/README.rst"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}