summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 21:01:16 +0100
committersL1pKn072019-03-02 21:01:16 +0100
commit4361342e32c7d6201c0ee876700627f9a2416fbe (patch)
tree9af41a7e8cace3eeaee2e2a7193e47a4f7487363
parent8ee49449cb901db70c4a6d5b0ccb38f5df30cef5 (diff)
downloadaur-4361342e32c7d6201c0ee876700627f9a2416fbe.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e363009ac18..4f42b0b00d34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:31:48 UTC 2015
+# Sat Mar 2 20:01:16 UTC 2019
pkgbase = vapoursynth-plugin-videoscope-git
pkgdesc = Plugin for Vapoursynth: videoscope (GIT version)
pkgver = v1.0.2.g527b9b0
pkgrel = 1
url = https://github.com/dubhater/vapoursynth-videoscope
- arch = i686
arch = x86_64
license = custom:WTFPL
makedepends = git
@@ -14,8 +13,8 @@ pkgbase = vapoursynth-plugin-videoscope-git
conflicts = vapoursynth-plugin-videoscope
source = videoscope::git+https://github.com/dubhater/vapoursynth-videoscope.git
source = COPYING::http://www.wtfpl.net/txt/copying/
- sha1sums = SKIP
- sha1sums = 337ece375beddfdb7392699fd00eb9b3e823d03f
+ sha256sums = SKIP
+ sha256sums = 0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5
pkgname = vapoursynth-plugin-videoscope-git
diff --git a/PKGBUILD b/PKGBUILD
index 25ca88bec65c..7112cd4c9e61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=v1.0.2.g527b9b0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/dubhater/vapoursynth-${_plug}"
license=('custom:WTFPL')
depends=('vapoursynth')
@@ -14,8 +14,9 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
'COPYING::http://www.wtfpl.net/txt/copying/')
-sha1sums=('SKIP'
- '337ece375beddfdb7392699fd00eb9b3e823d03f')
+sha256sums=('SKIP'
+ '0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5'
+ )
pkgver() {
cd "${_plug}"
@@ -23,18 +24,24 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure --libdir=/usr/lib/vapoursynth
+ cd build
+ ../"${_plug}"/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
make
}
package(){
- make -C "${_plug}" DESTDIR="${pkgdir}" install
- install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}