summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-12-25 23:31:58 +0100
committersl1pkn072015-12-25 23:31:58 +0100
commit8ee49449cb901db70c4a6d5b0ccb38f5df30cef5 (patch)
treed618d0a25630ad4c18ac3959f07710c92071fd8b
parentcf00f95bc32e58910c4c331b7f318a6ac9a75680 (diff)
downloadaur-8ee49449cb901db70c4a6d5b0ccb38f5df30cef5.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82ad635ce756..8e363009ac18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Dec 25 22:31:48 UTC 2015
pkgbase = vapoursynth-plugin-videoscope-git
pkgdesc = Plugin for Vapoursynth: videoscope (GIT version)
- pkgver = v1.0.1.g511aeeb
+ pkgver = v1.0.2.g527b9b0
pkgrel = 1
url = https://github.com/dubhater/vapoursynth-videoscope
arch = i686
@@ -11,9 +13,9 @@ pkgbase = vapoursynth-plugin-videoscope-git
provides = vapoursynth-plugin-videoscope
conflicts = vapoursynth-plugin-videoscope
source = videoscope::git+https://github.com/dubhater/vapoursynth-videoscope.git
- source = LICENSE::http://www.wtfpl.net/txt/copying/
- md5sums = SKIP
- md5sums = 8365d07beeb5f39d87e846dca3ae7b64
+ source = COPYING::http://www.wtfpl.net/txt/copying/
+ sha1sums = SKIP
+ sha1sums = 337ece375beddfdb7392699fd00eb9b3e823d03f
pkgname = vapoursynth-plugin-videoscope-git
diff --git a/PKGBUILD b/PKGBUILD
index b71d4a9990b4..25ca88bec65c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=videoscope
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.1.g511aeeb
+pkgver=v1.0.2.g527b9b0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -13,26 +13,28 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
- 'LICENSE::http://www.wtfpl.net/txt/copying/')
-md5sums=('SKIP'
- '8365d07beeb5f39d87e846dca3ae7b64')
-_gitname="${_plug}"
+ 'COPYING::http://www.wtfpl.net/txt/copying/')
+sha1sums=('SKIP'
+ '337ece375beddfdb7392699fd00eb9b3e823d03f')
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-build() {
- cd "${_gitname}"
+prepare() {
+ cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --libdir=/usr/lib/vapoursynth
make
}
package(){
- cd "${_gitname}"
- make DESTDIR="$pkgdir" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
- install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make -C "${_plug}" DESTDIR="${pkgdir}" install
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}