summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:40:04 +0200
committersl1pkn072015-06-08 20:40:04 +0200
commitcf00f95bc32e58910c4c331b7f318a6ac9a75680 (patch)
tree2f7ad35e519b102a164d616fc4a91467ab7bb0f0
downloadaur-cf00f95bc32e58910c4c331b7f318a6ac9a75680.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82ad635ce756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vapoursynth-plugin-videoscope-git
+ pkgdesc = Plugin for Vapoursynth: videoscope (GIT version)
+ pkgver = v1.0.1.g511aeeb
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-videoscope
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-videoscope
+ conflicts = vapoursynth-plugin-videoscope
+ source = videoscope::git+https://github.com/dubhater/vapoursynth-videoscope.git
+ source = LICENSE::http://www.wtfpl.net/txt/copying/
+ md5sums = SKIP
+ md5sums = 8365d07beeb5f39d87e846dca3ae7b64
+
+pkgname = vapoursynth-plugin-videoscope-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b71d4a9990b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=videoscope
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.1.g511aeeb
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/dubhater/vapoursynth-${_plug}"
+license=('custom:WTFPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
+ 'LICENSE::http://www.wtfpl.net/txt/copying/')
+md5sums=('SKIP'
+ '8365d07beeb5f39d87e846dca3ae7b64')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}