summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-05-23 01:16:18 +0200
committersL1pKn072023-05-23 01:16:18 +0200
commit9bc3a16f30882ab4089709c7d02c703aba741a12 (patch)
tree50f55af971f04921e4db6f43b6b11d5a898f7e73
downloadaur-9bc3a16f30882ab4089709c7d02c703aba741a12.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33106f9806e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = vapoursynth-plugin-vsadjust-git
+ pkgdesc = Plugin for Vapoursynth: vsadjust (GIT version)
+ pkgver = r12.3f1fb35
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/vs-adjust.git
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
+ makedepends = python-setuptools
+ depends = vapoursynth
+ depends = vapoursynth-plugin-vstools-git
+ depends = vapoursynth-plugin-vskernels-git
+ depends = vapoursynth-plugin-vsexprtools-git
+ depends = vapoursynth-plugin-vsrgtools-git
+ depends = vapoursynth-plugin-vsmask-git
+ depends = vapoursynth-plugin-vsaa-git
+ depends = vapoursynth-plugin-vsscale-git
+ provides = vapoursynth-plugin-vsadjust
+ conflicts = vapoursynth-plugin-vsadjust
+ source = vsadjust::git+https://github.com/Irrational-Encoding-Wizardry/vs-adjust.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vsadjust-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97f20ad68e8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vsadjust
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r12.3f1fb35
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/Irrational-Encoding-Wizardry/vs-adjust.git'
+license=('MIT')
+depends=(
+ 'vapoursynth'
+ 'vapoursynth-plugin-vstools-git'
+ 'vapoursynth-plugin-vskernels-git'
+ 'vapoursynth-plugin-vsexprtools-git'
+ 'vapoursynth-plugin-vsrgtools-git'
+ 'vapoursynth-plugin-vsmask-git'
+ 'vapoursynth-plugin-vsaa-git'
+ 'vapoursynth-plugin-vsscale-git'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-wheel'
+ 'python-installer'
+ 'python-setuptools'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/vs-adjust.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - . | tr -d v)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_plug}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_plug}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}