summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-11-18 16:32:17 +0100
committersL1pKn072022-11-18 16:32:17 +0100
commit03e24fdb52e59cef0df148ee1747b3db0545c4ee (patch)
tree224b916c5a83d02c31783229372ca0d7b9185749
downloadaur-03e24fdb52e59cef0df148ee1747b3db0545c4ee.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5238ca2d160a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vapoursynth-plugin-vsdfft-git
+ pkgdesc = Plugin for Vapoursynth: vsdfft (GIT version)
+ pkgver = 1.0.0.3.g5584f85
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/vs-dfft.git
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-pip
+ makedepends = python-wheel
+ depends = vapoursynth-plugin-vstools-git
+ depends = vapoursynth-plugin-vskernels-git
+ depends = vapoursynth-plugin-vsexprtools-git
+ depends = vapoursynth-plugin-vsrgtools-git
+ depends = vapoursynth-plugin-vsmask-git
+ provides = vapoursynth-plugin-vsdfft
+ conflicts = vapoursynth-plugin-vsdfft
+ source = vsdfft::git+https://github.com/Irrational-Encoding-Wizardry/vs-dfft.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vsdfft-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acff8b4cbad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vsdfft
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=1.0.0.3.g5584f85
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/Irrational-Encoding-Wizardry/vs-dfft.git'
+license=('GPL')
+depends=('vapoursynth-plugin-vstools-git'
+ 'vapoursynth-plugin-vskernels-git'
+ 'vapoursynth-plugin-vsexprtools-git'
+ 'vapoursynth-plugin-vsrgtools-git'
+ 'vapoursynth-plugin-vsmask-git'
+ )
+makedepends=('git'
+ 'python-pip'
+ 'python-wheel'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/vs-dfft.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
+}
+
+build() {
+ cd "${_plug}"
+ pip wheel --no-deps . -w dist
+}
+
+package() {
+ cd "${_plug}"
+ pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}