summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Holmer2023-03-31 11:45:22 -0400
committerJoshua Holmer2023-03-31 11:45:22 -0400
commitf0c00188b491e0a830e482f56e604248f96a1913 (patch)
tree1607d225f07e7137e12ff70ab5d25acb149558cf
downloadaur-vapoursynth-plugin-vsengine-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..184e39235ede
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-vsengine-git
+ pkgdesc = Plugin for Vapoursynth: vsengine (GIT version)
+ pkgver = 0.2.0.0.gddbb628
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/vs-engine
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-pip
+ makedepends = python-wheel
+ depends = vapoursynth
+ provides = vapoursynth-plugin-vsengine
+ conflicts = vapoursynth-plugin-vsengine
+ source = vsengine::git+https://github.com/Irrational-Encoding-Wizardry/vs-engine.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vsengine-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bc2bff12d1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vsengine
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=0.2.0.0.gddbb628
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/Irrational-Encoding-Wizardry/vs-engine'
+license=('MIT')
+depends=('vapoursynth'
+)
+makedepends=('git'
+ 'python-pip'
+ 'python-wheel'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/vs-engine.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
+}
+
+build() {
+ cd "${_plug}"
+ pip wheel --no-deps . -w dist
+}
+
+package() {
+ cd "${_plug}"
+ pip install -I -U --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}