summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-02-26 21:28:12 +0100
committersL1pKn072020-02-26 21:28:12 +0100
commitc02e172d7a41c912814ebf516ac8aba40b7ef848 (patch)
tree00258dbbca64ffdd8787874254ce725e44d5b347
downloadaur-c02e172d7a41c912814ebf516ac8aba40b7ef848.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adea70ed537e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vapoursynth-plugin-vsgan-git
+ pkgdesc = Plugin for Vapoursynth: vsgan (GIT version)
+ pkgver = v1.0.8.r25.8b166f9
+ pkgrel = 1
+ url = https://github.com/rlaPHOENiX/VSGAN
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = vapoursynth-plugin-mvsfunc-git
+ depends = python-numpy
+ depends = python-pytorch
+ provides = vapoursynth-plugin-vsgan
+ conflicts = vapoursynth-plugin-vsgan
+ source = vsgan::git+https://github.com/rlaPHOENiX/VSGAN.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vsgan-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6456ffeef503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vsgan
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.8.r25.8b166f9
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/rlaPHOENiX/VSGAN'
+license=('GPL')
+depends=('vapoursynth-plugin-mvsfunc-git'
+ 'python-numpy'
+ 'python-pytorch'
+ )
+makedepends=('git'
+ 'python-setuptools'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/rlaPHOENiX/VSGAN.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ _ver="$(cat setup.py | grep -m1 version | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "v${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_plug}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}