summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:40:09 +0200
committersl1pkn072015-06-08 20:40:09 +0200
commite26956a7c1c529d4d43173fc6e2f3ef4f8713f03 (patch)
treeb61bf33438e8a999d9ead44a29523a6bc2870655
downloadaur-e26956a7c1c529d4d43173fc6e2f3ef4f8713f03.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abb2d117ba40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-vshelpers-git
+ pkgdesc = Plugin for Vapoursynth: vshelpers (GIT version)
+ pkgver = r1
+ pkgrel = 1
+ url = https://gist.github.com/4re
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-vshelpers
+ conflicts = vapoursynth-plugin-vshelpers
+ source = vshelpers::git+https://gist.github.com/bba3f65469acfe0ec08a.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-vshelpers-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb4ee57b4f95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vshelpers
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url="https://gist.github.com/4re"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://gist.github.com/bba3f65469acfe0ec08a.git")
+sha1sums=('SKIP')
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}