summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhs2020-10-07 12:07:39 +0000
committerzhs2020-10-07 12:07:39 +0000
commita81973d4bd46b402e3617c6d2de4955a7796896a (patch)
treeb4e43b22a6bc2d13daf915be9c33b52a94389f53
parent81fc95e0df22352b619e805bfbff58fb50e690f0 (diff)
downloadaur-a81973d4bd46b402e3617c6d2de4955a7796896a.tar.gz
refining touches to satisfy namcap
-rw-r--r--Makefile.custom5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.custom b/Makefile.custom
index 1e8229b18a63..df9b8afb55e3 100644
--- a/Makefile.custom
+++ b/Makefile.custom
@@ -3,8 +3,9 @@ DESTDIR ?=
CXXFLAGS=-std=c++11 -Wno-unknown-pragmas -Wall \
-fPIC -march=native -O2 -pipe -fno-plt -DFORTIFY_SOURCE=2 \
- -I/usr/include/mxnet -I/usr/include/vapoursynth -I/usr/include/opencv4
-LDFLAGS=-shared -fPIC -lpthread -lmxnet
+ -I/usr/include/mxnet -I/usr/include/vapoursynth
+LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now \
+ -shared -fPIC -lpthread -lmxnet
all: libvsmxnet.so
diff --git a/PKGBUILD b/PKGBUILD
index debdca25da1c..231d78e04280 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@ pkgrel=1
pkgdesc="Use MXNet to accelerate image processing in VapourSynth (git version), modified to compile on Linux"
arch=('x86_64')
url="https://github.com/kice/vs_mxnet"
-license=('MPL-2.0')
-depends=('vapoursynth' 'mxnet' 'opencv')
-makedepends=('git' 'vapoursynth' 'mxnet' 'opencv')
+license=('MPL2')
+depends=('vapoursynth' 'mxnet')
+makedepends=('git')
source=("git+https://github.com/kice/vs_mxnet"
"Makefile.custom"
"linux-compile.patch")
sha256sums=('SKIP'
- '8b3beb81026a70a6b3ade61e3a84d49627c5b7fa36247a1c86d8b0a4ee323fe0'
+ '6b214d9e7a2c227813b62087365453d181e7be40f82fca7f4573da04792acfe5'
'ba5011e9e638d64db622b9080b3b2c423ce6941f9d248088e7aec10f0f6f7b59')
pkgver() {