summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhs2020-10-07 12:33:05 +0000
committerzhs2020-10-07 12:33:05 +0000
commitfb2b88d0955cc5ebc099674a09dd979f66a2db1d (patch)
tree2a1bb0f966b64a2ed5c89ea080fe9723a85c3535
parenta81973d4bd46b402e3617c6d2de4955a7796896a (diff)
downloadaur-fb2b88d0955cc5ebc099674a09dd979f66a2db1d.tar.gz
fixing an error that prevented loading of the shared library
-rw-r--r--Makefile.custom2
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.custom b/Makefile.custom
index df9b8afb55e3..c6206f3a916f 100644
--- a/Makefile.custom
+++ b/Makefile.custom
@@ -4,7 +4,7 @@ DESTDIR ?=
CXXFLAGS=-std=c++11 -Wno-unknown-pragmas -Wall \
-fPIC -march=native -O2 -pipe -fno-plt -DFORTIFY_SOURCE=2 \
-I/usr/include/mxnet -I/usr/include/vapoursynth
-LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now \
+LDFLAGS=-Wl,-z,relro,-z,now \
-shared -fPIC -lpthread -lmxnet
all: libvsmxnet.so
diff --git a/PKGBUILD b/PKGBUILD
index 231d78e04280..565210e77317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ source=("git+https://github.com/kice/vs_mxnet"
"Makefile.custom"
"linux-compile.patch")
sha256sums=('SKIP'
- '6b214d9e7a2c227813b62087365453d181e7be40f82fca7f4573da04792acfe5'
+ 'ad9c5a4705b259b39c166b4c830ae18896eb0379dc2d412ad039ad7781642592'
'ba5011e9e638d64db622b9080b3b2c423ce6941f9d248088e7aec10f0f6f7b59')
pkgver() {