summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072024-03-29 02:58:03 +0100
committersL1pKn072024-03-29 02:58:03 +0100
commit59eb40dd5dd6398adfac1d04975c05bac3733b7d (patch)
treea439cffab67882f9b3a29b9a7a899e9694ec1197
downloadaur-59eb40dd5dd6398adfac1d04975c05bac3733b7d.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42f51551c704
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vapoursynth-plugin-vstransitions-git
+ pkgdesc = Plugin for Vapoursynth: vstransitions (GIT version)
+ pkgver = r17.ce3067f
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/vs-transitions.git
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
+ makedepends = python-setuptools
+ depends = vapoursynth
+ depends = vapoursynth-plugin-vstools-git
+ depends = vapoursynth-plugin-vskernels-git
+ depends = vapoursynth-plugin-vsexprtools-git
+ provides = vapoursynth-plugin-vstransitions
+ conflicts = vapoursynth-plugin-vstransitions
+ source = vstransitions::git+https://github.com/Irrational-Encoding-Wizardry/vs-transitions.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vstransitions-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f00aaa9fee88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vstransitions
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r17.ce3067f
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/Irrational-Encoding-Wizardry/vs-transitions.git'
+license=('MIT')
+depends=(
+ 'vapoursynth'
+ 'vapoursynth-plugin-vstools-git'
+ 'vapoursynth-plugin-vskernels-git'
+ 'vapoursynth-plugin-vsexprtools-git'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-wheel'
+ 'python-installer'
+ 'python-setuptools'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/vs-transitions.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - . | tr -d v)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_plug}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_plug}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}