summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-06-26 12:45:38 +0200
committerGustavo Alvarez2016-06-26 12:45:38 +0200
commit8c8a8d240a3793dbbaef3b0718ea8ce934c78656 (patch)
tree136ba1a1dab89b6fc58967587c2771e5e94a6974
downloadaur-8c8a8d240a3793dbbaef3b0718ea8ce934c78656.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c54fcc3d694
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jun 26 10:45:38 UTC 2016
+pkgbase = vapoursynth-plugin-w3fdif-git
+ pkgdesc = Plugin for Vapoursynth: w3fdif (GIT version)
+ pkgver = r1.0.gd70b08e
+ pkgrel = 1
+ url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-W3FDIF
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-w3fdif
+ conflicts = vapoursynth-plugin-w3fdif
+ source = w3fdif::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-W3FDIF.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-w3fdif-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66f90e64ad45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=w3fdif
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.0.gd70b08e
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/HomeOfVapourSynthEvolution/VapourSynth-W3FDIF'
+license=('LGPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-W3FDIF.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --install="${pkgdir}/usr/lib/vapoursynth" \
+ --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
+ --extra-ldflags="${LDFLAGS}"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}