summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-05-27 23:25:16 +0200
committersL1pKn072018-05-27 23:25:16 +0200
commita2cb7af6f1472a880e3cc907ff7af7b172be75b1 (patch)
treeb21fa4d4b98eb3a23e89a0fcec1e6d66cf762eef
parent3d22c25663be67a9aeedcf306ceafceccee9415b (diff)
downloadaur-a2cb7af6f1472a880e3cc907ff7af7b172be75b1.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3807352f3f32..7cb6269a696d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun May 27 21:25:10 UTC 2018
pkgbase = vapoursynth-plugin-waifu2x-w2xc-git
pkgdesc = Plugin for Vapoursynth: waifu2x-w2xc (GIT version)
- pkgver = r6.7.g9cea4dd
+ pkgver = r6.9.g4128c53
pkgrel = 1
url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Waifu2x-w2xc/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index e4aff5ab9bd5..d443a1c8eed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer : Yamashita Ren
-# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer : Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Yamashita Ren
_plug=waifu2x-w2xc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r6.7.g9cea4dd
+pkgver=r6.9.g4128c53
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -21,17 +21,26 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
-build() {
+prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
- make
+
+ cd "${srcdir}/build"
+ ../"${_plug}"/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
+}
+
+build() {
+ make -C build
}
package(){
- cd "${_plug}"
- make install
- cp -R Waifu2x-w2xc/models ${pkgdir}/usr/lib/vapoursynth/models
+ make -C build DESTDIR="${pkgdir}" install
+ cp -R "${_plug}/Waifu2x-w2xc/models" ${pkgdir}/usr/lib/vapoursynth/models
chmod -R a+w ${pkgdir}/usr/lib/vapoursynth/models
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}