summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-06-20 21:50:46 +0200
committersL1pKn072019-06-20 21:50:46 +0200
commita89217036e66f9dc1abcb291882452ca31d88c41 (patch)
tree08fa6be682f5703b4debd0f59cc1099b722b863d
parente89dc584bba8c5f1467e9204e2a26ddf89ccfcac (diff)
downloadaur-a89217036e66f9dc1abcb291882452ca31d88c41.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a849c1ef8ee..f3cba5517e8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Fri Apr 12 23:32:46 UTC 2019
pkgbase = vapoursynth-plugin-waifu2x-w2xc-git
pkgdesc = Plugin for Vapoursynth: waifu2x-w2xc (GIT version)
- pkgver = r7.0.g4128c53
+ pkgver = r8.0.gec6da15
pkgrel = 1
url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Waifu2x-w2xc
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = meson
depends = vapoursynth
depends = waifu2x-converter-cpp
provides = vapoursynth-plugin-waifu2x-w2xc
diff --git a/PKGBUILD b/PKGBUILD
index 14bbcb03bf05..21af98ed07fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_plug=waifu2x-w2xc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r7.0.g4128c53
+pkgver=r8.0.gec6da15
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -12,7 +12,9 @@ license=('GPL2')
depends=('vapoursynth'
'waifu2x-converter-cpp'
)
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-${_plug}.git")
@@ -25,24 +27,18 @@ pkgver() {
prepare() {
mkdir -p build
-
- cd "${_plug}"
- ./autogen.sh
}
build() {
cd build
- ../"${_plug}"/configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- make -C build DESTDIR="${pkgdir}" install
- cp -R "${_plug}/Waifu2x-w2xc/models" ${pkgdir}/usr/lib/vapoursynth/models
- chmod -R a+w "${pkgdir}/usr/lib/vapoursynth/models"
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}