summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 20:33:40 +0100
committersL1pKn072019-02-08 20:33:40 +0100
commit3d71548af717014a7802135322024f68b5c06982 (patch)
tree7c865f37c4a4293d01aabeda50304f8c18245393
downloadaur-3d71548af717014a7802135322024f68b5c06982.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf306466c4f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Feb 8 19:33:40 UTC 2019
+pkgbase = vapoursynth-plugin-warpsharpsupport-git
+ pkgdesc = Plugin for Vapoursynth: warpsharpsupport
+ pkgver = R1.0.g42f3b5e
+ pkgrel = 1
+ url = https://github.com/myrsloik/WarpSharpSupport.git
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ source = warpsharpsupport::git+https://github.com/myrsloik/WarpSharpSupport.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-warpsharpsupport-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..571cb3343555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=warpsharpsupport
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=R1.0.g42f3b5e
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('any')
+url='https://github.com/myrsloik/WarpSharpSupport.git'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+source=("${_plug}::git+https://github.com/myrsloik/WarpSharpSupport.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package() {
+ install -Dm644 "${_plug}/wss.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}