summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-27 19:12:18 +0100
committersL1pKn072019-03-27 19:12:18 +0100
commit95e9e12c63552bb27f06c587921aeb21e1d03744 (patch)
treebcd2616218f3073e08f5ee495f9f24bc8e72db7a
downloadaur-95e9e12c63552bb27f06c587921aeb21e1d03744.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e69560943846
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 18:12:18 UTC 2019
+pkgbase = vapoursynth-plugin-xaa-git
+ pkgdesc = Plugin for Vapoursynth: xaa (GIT version)
+ pkgver = v2.0.ga7766a0
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-xaa
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = vapoursynth-plugin-eedi2-git
+ depends = vapoursynth-plugin-eedi3cl-git
+ depends = vapoursynth-plugin-nnedi3cl-git
+ depends = vapoursynth-plugin-sangnom
+ depends = vapoursynth-plugin-tcanny-git
+ depends = vapoursynth-plugin-tedgemask-git
+ depends = vapoursynth-plugin-znedi3-git
+ provides = vapoursynth-plugin-xaa
+ conflicts = vapoursynth-plugin-xaa
+ source = xaa::git+https://github.com/dubhater/vapoursynth-xaa.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-xaa-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63e0785c6b73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=xaa
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v2.0.ga7766a0
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://github.com/dubhater/vapoursynth-${_plug}"
+license=('GPL')
+depends=('vapoursynth'
+ 'vapoursynth-plugin-eedi2-git'
+ 'vapoursynth-plugin-eedi3cl-git'
+ 'vapoursynth-plugin-nnedi3cl-git'
+ 'vapoursynth-plugin-sangnom'
+ 'vapoursynth-plugin-tcanny-git'
+ 'vapoursynth-plugin-tedgemask-git'
+ 'vapoursynth-plugin-znedi3-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+} \ No newline at end of file