summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-03-10 15:31:01 +0100
committersL1pKn072017-03-10 15:31:01 +0100
commit93db90d18cf218f8c64e4613e210f22917a96b7a (patch)
treeaa2d3b948301d9de0a95695fd053106eba48c1ac
parentf6083c17e7ab6c859d9fc5d6d777708f89bc239e (diff)
downloadaur-93db90d18cf218f8c64e4613e210f22917a96b7a.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c385efb303e8..8d10e304eeb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Mar 15 17:42:15 UTC 2016
+# Fri Mar 10 14:30:53 UTC 2017
pkgbase = vapoursynth-plugin-yadifmod-git
pkgdesc = Plugin for Vapoursynth: yadifmod (GIT Version)
- pkgver = r9.2.gdf73634
+ pkgver = r10.0.g89e70a1
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171028
arch = i686
@@ -13,7 +13,7 @@ pkgbase = vapoursynth-plugin-yadifmod-git
provides = vapoursynth-plugin-yadifmod
conflicts = vapoursynth-plugin-yadifmod
source = yadifmod::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Yadifmod.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-yadifmod-git
diff --git a/PKGBUILD b/PKGBUILD
index 3263bc1e39ca..7eec3712c89b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=yadifmod
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r9.2.gdf73634
+pkgver=r10.0.g89e70a1
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
arch=('i686' 'x86_64')
@@ -13,24 +13,29 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Yadifmod.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
build() {
cd "${_plug}"
./configure \
- --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
make
}
package(){
cd "${_plug}"
- make install
+ make DESTDIR="${pkgdir}" install
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}