summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 19:10:50 +0100
committersL1pKn072019-02-08 19:10:50 +0100
commitabb358eb154630650e463116685ba7b321ffb07b (patch)
tree407d2c72d94d722bf66fb603c250072632056b81
parent93db90d18cf218f8c64e4613e210f22917a96b7a (diff)
downloadaur-abb358eb154630650e463116685ba7b321ffb07b.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d10e304eeb6..4e143e1ebd98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Mar 10 14:30:53 UTC 2017
+# Fri Feb 8 18:10:44 UTC 2019
pkgbase = vapoursynth-plugin-yadifmod-git
pkgdesc = Plugin for Vapoursynth: yadifmod (GIT Version)
- pkgver = r10.0.g89e70a1
+ pkgver = r10.1.0.g8aad01a
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171028
- arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = meson
depends = vapoursynth
provides = vapoursynth-plugin-yadifmod
conflicts = vapoursynth-plugin-yadifmod
diff --git a/PKGBUILD b/PKGBUILD
index 7eec3712c89b..4da1ec4036de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
_plug=yadifmod
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r10.0.g89e70a1
+pkgver=r10.1.0.g8aad01a
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://forum.doom9.org/showthread.php?t=171028'
license=('GPL')
depends=('vapoursynth')
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Yadifmod.git")
@@ -21,21 +23,19 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
- ./autogen.sh
+ mkdir -p build
}
build() {
- cd "${_plug}"
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
+ cd build
+ CXXFLAGS+=' -fpeel-loops' arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}