summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:40:32 +0200
committersl1pkn072015-06-08 20:40:32 +0200
commitd3f60028010f14bf68a90b86f4f626d840061969 (patch)
tree678cc6e9cac8b7338607510456f07a3cd8ef2efb
downloadaur-d3f60028010f14bf68a90b86f4f626d840061969.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..298623fab7a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-yadifmod-git
+ pkgdesc = Plugin for Vapoursynth: yadifmod (GIT Version)
+ pkgver = r7.3.gff545ec
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171028
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth--plugin-yadifmod
+ conflicts = vapoursynth-plugin-yadifmod
+ source = yadifmod::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Yadifmod.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-yadifmod-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f43791177ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=yadifmod
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r7.3.gff545ec
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171028"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth--plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Yadifmod.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ make -C "${_plug}" install
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}