summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 19:59:47 +0100
committersL1pKn072022-03-13 19:59:47 +0100
commit0be92cd00f544cddd52033f283ac8a2cb01077a1 (patch)
tree47d9a30efb385a2c26672c4c3da64f43b2cd4349
parent1f8e1e2e51937af32016382a47405c6e0e4fc746 (diff)
downloadaur-0be92cd00f544cddd52033f283ac8a2cb01077a1.tar.gz
bump
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd55b08434fb..93f462815b1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-znedi3-git
pkgdesc = Plugin for Vapoursynth: znedi3 (GIT Version)
- pkgver = r2.1.4.g643e4b4
+ pkgver = 2.1.4.g643e4b4
pkgrel = 1
url = https://github.com/sekrit-twc/znedi3
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = vapoursynth-plugin-znedi3-git
depends = vapoursynth-plugin-nnedi3_weights_bin
provides = vapoursynth-plugin-znedi3
conflicts = vapoursynth-plugin-znedi3
+ options = debug
source = znedi3::git+https://github.com/JeremyMahieu/znedi3.git
source = git+https://github.com/sekrit-twc/vsxx.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9e7d1c31d616..5a4ffb0a8499 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
# Contributor: Mikuro Kagamine <mikurok@forgecrushing.com>
_plug=znedi3
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r2.1.4.g643e4b4
+pkgver=2.1.4.g643e4b4
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
arch=('x86_64')
@@ -21,10 +21,11 @@ source=("${_plug}::git+https://github.com/JeremyMahieu/${_plug}.git"
sha256sums=('SKIP'
'SKIP'
)
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d r)"
}
prepare() {
@@ -47,9 +48,9 @@ prepare() {
}
build() {
+ cd "${_plug}"
CXXFLAGS+=" $(pkg-config --cflags vapoursynth)"
CPPFLAGS+=" -DNNEDI3_WEIGHTS_PATH=\\\"/usr/lib/vapoursynth/nnedi3_weights.bin\\\""
- cd "${_plug}"
LC_ALL=C make V=1 X86=1
}