summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-09 21:52:18 +0100
committersL1pKn072022-02-09 21:52:18 +0100
commit1f8e1e2e51937af32016382a47405c6e0e4fc746 (patch)
tree0d421573c7e279cb0bee1d6919aac8f4d02d9dd4
parent3fe4eb3fc9bde0d6581fa362ef0d991fd20a26d1 (diff)
downloadaur-1f8e1e2e51937af32016382a47405c6e0e4fc746.tar.gz
swiching to fork
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c7153761863..bd55b08434fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-znedi3-git
pkgdesc = Plugin for Vapoursynth: znedi3 (GIT Version)
- pkgver = r1.9.gacb7cc3
+ pkgver = r2.1.4.g643e4b4
pkgrel = 1
url = https://github.com/sekrit-twc/znedi3
arch = x86_64
@@ -10,10 +10,9 @@ pkgbase = vapoursynth-plugin-znedi3-git
depends = vapoursynth-plugin-nnedi3_weights_bin
provides = vapoursynth-plugin-znedi3
conflicts = vapoursynth-plugin-znedi3
- source = znedi3::git+https://github.com/sekrit-twc/znedi3.git
+ source = znedi3::git+https://github.com/JeremyMahieu/znedi3.git
source = git+https://github.com/sekrit-twc/vsxx.git
sha256sums = SKIP
sha256sums = SKIP
pkgname = vapoursynth-plugin-znedi3-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 602d8861a34d..9e7d1c31d616 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_plug=znedi3
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r1.9.gacb7cc3
+pkgver=r2.1.4.g643e4b4
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
arch=('x86_64')
@@ -15,7 +15,7 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/sekrit-twc/${_plug}.git"
+source=("${_plug}::git+https://github.com/JeremyMahieu/${_plug}.git"
'git+https://github.com/sekrit-twc/vsxx.git'
)
sha256sums=('SKIP'
@@ -30,26 +30,27 @@ pkgver() {
prepare() {
cd "${_plug}"
git config submodule.vsplugin/vsxx.url "${srcdir}/vsxx"
- git submodule update --init
+ git submodule update --init vsxx
# use system vapoursynth headers
- rm -fr vsxx/VapourSynth.h
- rm -fr vsxx/VSScript.h
- rm -fr vsxx/VSHelper.h
-
- sed -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
- -e 's|"VSHelper.h"|<VSHelper.h>|g' \
- -i vsxx/VapourSynth++.hpp
-
- sed -e "s|-Ivsxx|& $(pkg-config --cflags vapoursynth)|g" \
- -e '/VSScript.h/d' \
- -e '/VapourSynth.h/d' \
- -e '/VSHelper.h/d'\
+ rm -fr vsxx/VapourSynth
+
+ sed -e 's|"VapourSynth4.h"|<VapourSynth4.h>|g' \
+ -e 's|"VSHelper4.h"|<VSHelper4.h>|g' \
+ -i vsxx/VapourSynth4++.hpp
+
+ sed -e 's|-Ivsxx/VapourSynth||g' \
+ -e '/VSScript4.h/d' \
+ -e '/VapourSynth4.h/d' \
+ -e '/VSHelper4.h/d' \
-i Makefile
}
build() {
- make -C "${_plug}" X86=1 CPPFLAGS="-DNNEDI3_WEIGHTS_PATH=\\\"\"/usr/lib/vapoursynth/nnedi3_weights.bin\"\\\""
+ CXXFLAGS+=" $(pkg-config --cflags vapoursynth)"
+ CPPFLAGS+=" -DNNEDI3_WEIGHTS_PATH=\\\"/usr/lib/vapoursynth/nnedi3_weights.bin\\\""
+ cd "${_plug}"
+ LC_ALL=C make V=1 X86=1
}
package(){