summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-06-25 02:11:35 +0200
committersL1pKn072022-06-25 02:11:35 +0200
commit9d404d8758f447da019205ee302a5c13d6ae9a9a (patch)
tree595a23617f51e4645d713a557b05d482c365ad57
parent0be92cd00f544cddd52033f283ac8a2cb01077a1 (diff)
downloadaur-9d404d8758f447da019205ee302a5c13d6ae9a9a.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93f462815b1e..67442d9c2ed4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-znedi3-git
pkgdesc = Plugin for Vapoursynth: znedi3 (GIT Version)
- pkgver = 2.1.4.g643e4b4
+ pkgver = 2.1.16.g97940d2
pkgrel = 1
url = https://github.com/sekrit-twc/znedi3
arch = x86_64
@@ -11,8 +11,10 @@ pkgbase = vapoursynth-plugin-znedi3-git
provides = vapoursynth-plugin-znedi3
conflicts = vapoursynth-plugin-znedi3
options = debug
- source = znedi3::git+https://github.com/JeremyMahieu/znedi3.git
+ source = znedi3::git+https://github.com/sekrit-twc/znedi3.git
source = git+https://github.com/sekrit-twc/vsxx.git
+ source = git+https://github.com/sekrit-twc/graphengine.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5a4ffb0a8499..5528e937135c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_plug=znedi3
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=2.1.4.g643e4b4
+pkgver=2.1.16.g97940d2
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
arch=('x86_64')
@@ -15,11 +15,13 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/JeremyMahieu/${_plug}.git"
+source=("${_plug}::git+https://github.com/sekrit-twc/${_plug}.git"
'git+https://github.com/sekrit-twc/vsxx.git'
+ 'git+https://github.com/sekrit-twc/graphengine.git'
)
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
)
options=('debug')
@@ -31,27 +33,25 @@ pkgver() {
prepare() {
cd "${_plug}"
git config submodule.vsplugin/vsxx.url "${srcdir}/vsxx"
- git submodule update --init vsxx
+ git config submodule.graphengine.url "${srcdir}/graphengine"
+ git submodule update --init vsxx graphengine
# use system vapoursynth headers
rm -fr vsxx/VapourSynth
sed -e 's|"VapourSynth4.h"|<VapourSynth4.h>|g' \
- -e 's|"VSHelper4.h"|<VSHelper4.h>|g' \
-i vsxx/VapourSynth4++.hpp
- sed -e 's|-Ivsxx/VapourSynth||g' \
- -e '/VSScript4.h/d' \
- -e '/VapourSynth4.h/d' \
- -e '/VSHelper4.h/d' \
- -i Makefile
+ sed 's| -I/usr/include/vapoursynth/||g' \
+ -i Makefile
+
}
build() {
cd "${_plug}"
- CXXFLAGS+=" $(pkg-config --cflags vapoursynth)"
+ CXXFLAGS+=" $(pkg-config --cflags vapoursynth) -I$(pwd)/graphengine/include -I$(pwd)/znedi3 -I$(pwd)/vsxx -fPIC"
CPPFLAGS+=" -DNNEDI3_WEIGHTS_PATH=\\\"/usr/lib/vapoursynth/nnedi3_weights.bin\\\""
- LC_ALL=C make V=1 X86=1
+ LC_ALL=C make V=1 X86=1 X86_AVX512=1
}
package(){