summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikuro Kagamine2018-01-30 12:18:14 +1000
committerMikuro Kagamine2018-01-30 12:18:14 +1000
commitf3dae033e49cab9cf8f62cb61c3c8f619d439852 (patch)
tree4e6de60efcd0d8ca8a1b66e86192e9aa0e8fa987
downloadaur-f3dae033e49cab9cf8f62cb61c3c8f619d439852.tar.gz
Initial package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd120d4a8d9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vapoursynth-plugin-znedi3-git
+ pkgdesc = Plugin for Vapoursynth: znedi3 (GIT version)
+ pkgver = r1.1.gb4a2013
+ pkgrel = 1
+ url = https://github.com/sekrit-twc/znedi3
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-znedi3
+ conflicts = vapoursynth-plugin-znedi3
+
+pkgname = vapoursynth-plugin-znedi3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c225e552d5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Mikuro Kagamine <mikurok@forgecrushing.com>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=znedi3
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.1.gb4a2013
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/sekrit-twc/znedi3'
+license=('GPL2')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=()
+sha1sums=()
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ git clone --recursive https://github.com/sekrit-twc/znedi3
+}
+
+build() {
+ cd "${_plug}"
+ make X86=1
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm755 vsznedi3.so "${pkgdir}/usr/lib/vapoursynth/vsznedi3.so"
+ install -Dm755 nnedi3_weights.bin "${pkgdir}/usr/lib/vapoursynth/nnedi3_weights.bin"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}