summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwallace2019-10-22 15:53:29 +0900
committerwallace2019-10-22 15:53:29 +0900
commite4a979eb3ee29809440182ad5545d1c40c95b381 (patch)
treef64c341ecb600c236477c85b039bf1724a9e9747
downloadaur-e4a979eb3ee29809440182ad5545d1c40c95b381.tar.gz
Initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--vspreview4
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..064e89957086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vapoursynth-preview-git
+ pkgdesc = Preview for VapourSynth scripts
+ pkgver = r144.2fbc158
+ pkgrel = 1
+ url = https://github.com/Endilll/vapoursynth-preview
+ arch = any
+ license = Apache-2.0
+ depends = vapoursynth
+ depends = python-psutil
+ depends = python-pyqt5
+ depends = python-pyaml
+ depends = python-qdarkstyle
+ optdepends = python-cueparser
+ optdepends = python-pysubs2
+ source = git+https://github.com/Endilll/vapoursynth-preview.git
+ source = vspreview
+ sha512sums = SKIP
+ sha512sums = 54f7f97a3f5aa23e447a23e4a7f92e3bc38dad8521e922a3dcffd3c73ec29225692a8a60541d287130a09070440a473ea7b3342029f2dd3c45b31d9ec92cda32
+
+pkgname = vapoursynth-preview-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61d1cec67c42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: wallace < str(11) + my_id at gmail dot com>
+
+_gitname=vapoursynth-preview
+pkgname=${_gitname}-git
+pkgdesc='Preview for VapourSynth scripts'
+pkgver=r144.2fbc158
+pkgrel=1
+arch=('any')
+url='https://github.com/Endilll/vapoursynth-preview'
+license=('Apache-2.0')
+depends=(
+ 'vapoursynth'
+ 'python-psutil'
+ 'python-pyqt5'
+ 'python-pyaml'
+ 'python-qdarkstyle')
+optdepends=('python-cueparser' 'python-pysubs2')
+source=('git+https://github.com/Endilll/vapoursynth-preview.git' 'vspreview')
+sha512sums=(
+ 'SKIP'
+ '54f7f97a3f5aa23e447a23e4a7f92e3bc38dad8521e922a3dcffd3c73ec29225692a8a60541d287130a09070440a473ea7b3342029f2dd3c45b31d9ec92cda32')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d "${pkgdir}/opt/${_gitname}"
+ cp -ra ${srcdir}/${_gitname}/* "${pkgdir}/opt/${_gitname}"
+ install -Dm 755 ../vspreview "${pkgdir}/usr/bin/vspreview"
+}
diff --git a/vspreview b/vspreview
new file mode 100644
index 000000000000..a9f3f00ddbd2
--- /dev/null
+++ b/vspreview
@@ -0,0 +1,4 @@
+#!/usr/bin/env sh
+
+SCRIPT_DIR=/opt/vapoursynth-preview
+python ${SCRIPT_DIR}/run.py "$@"