summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-01-09 08:07:01 +0100
committersL1pKn072021-01-09 08:07:01 +0100
commit26eaaa3c6239a481bb88346724aa65fbe1aa5674 (patch)
treed447dd20d2045638a2bf09da68deb9a40cc1f043
downloadaur-26eaaa3c6239a481bb88346724aa65fbe1aa5674.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6af0a185f433
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vapoursynth-tools-getnative-git
+ pkgdesc = Tool for Vapoursynth: getnative (GIT version)
+ pkgver = 2.2.1.0.gc9519d9
+ pkgrel = 1
+ url = https://github.com/Infiziert90/getnative
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-matplotlib
+ depends = vapoursynth-plugin-descale
+ depends = vapoursynth-plugin-ffms2
+ depends = vapoursynth-plugin-lsmashsource
+ provides = vapoursynth-tools-getnative
+ conflicts = vapoursynth-tools-getnative
+ source = getnative::git+https://github.com/Infiziert90/getnative.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-tools-getnative-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6e530c99bb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dave <orangechannel@pm.me>
+
+_plug=getnative
+pkgname=vapoursynth-tools-${_plug}-git
+pkgver=2.2.1.0.gc9519d9
+pkgrel=1
+pkgdesc="Tool for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/Infiziert90/getnative'
+license=('MIT')
+depends=('python-matplotlib'
+ 'vapoursynth-plugin-descale'
+ 'vapoursynth-plugin-ffms2'
+ 'vapoursynth-plugin-lsmashsource'
+ )
+makedepends=('git')
+provides=("vapoursynth-tools-${_plug}")
+conflicts=("vapoursynth-tools-${_plug}" )
+source=("${_plug}::git+https://github.com/Infiziert90/getnative.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package(){
+ cd "${_plug}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}