summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-07 00:12:44 +0100
committersL1pKn072022-02-07 00:12:44 +0100
commit9d1c2605cadb7a9104cc350e9801238f4b310a7e (patch)
tree0bfcfe48991ee52d99ec7fa4821798f3fbc9a2ae
parent26eaaa3c6239a481bb88346724aa65fbe1aa5674 (diff)
downloadaur-9d1c2605cadb7a9104cc350e9801238f4b310a7e.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6af0a185f433..0e0ad83abbee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = vapoursynth-tools-getnative-git
pkgdesc = Tool for Vapoursynth: getnative (GIT version)
- pkgver = 2.2.1.0.gc9519d9
+ pkgver = 3.0.0.5.g13e46bd
pkgrel = 1
url = https://github.com/Infiziert90/getnative
arch = any
license = MIT
makedepends = git
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python-matplotlib
depends = vapoursynth-plugin-descale
depends = vapoursynth-plugin-ffms2
@@ -16,4 +18,3 @@ pkgbase = vapoursynth-tools-getnative-git
sha256sums = SKIP
pkgname = vapoursynth-tools-getnative-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e6e530c99bb4..25d1da2aeac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=getnative
pkgname=vapoursynth-tools-${_plug}-git
-pkgver=2.2.1.0.gc9519d9
+pkgver=3.0.0.5.g13e46bd
pkgrel=1
pkgdesc="Tool for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
@@ -13,7 +13,10 @@ depends=('python-matplotlib'
'vapoursynth-plugin-ffms2'
'vapoursynth-plugin-lsmashsource'
)
-makedepends=('git')
+makedepends=('git'
+ 'python-pip'
+ 'python-wheel'
+ )
provides=("vapoursynth-tools-${_plug}")
conflicts=("vapoursynth-tools-${_plug}" )
source=("${_plug}::git+https://github.com/Infiziert90/getnative.git")
@@ -24,9 +27,14 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
-package(){
+build() {
cd "${_plug}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ pip wheel --no-deps . -w dist
+}
+
+package() {
+ cd "${_plug}"
+ pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"