summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-19 06:23:39 +0100
committersL1pKn072020-03-19 06:23:39 +0100
commit309ca59806388c94ca9d1408ae11a577ab44b424 (patch)
tree55361036bae4427ce5660405dfe51a1134622f4f
downloadaur-309ca59806388c94ca9d1408ae11a577ab44b424.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ac40d4e5fe9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-tools-ocsuite-git
+ pkgdesc = Tools for Vapoursynth: ocsuite (GIT version)
+ pkgver = r2.132d838
+ pkgrel = 1
+ url = https://github.com/OrangeChannel/ocsuite
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-acsuite-git
+ depends = mkvtoolnix
+ provides = vapoursynth-tools-ocsuite
+ conflicts = vapoursynth-tools-ocsuite
+ source = ocsuite::git+https://github.com/OrangeChannel/ocsuite.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-tools-ocsuite-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3902f6414ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=ocsuite
+pkgname=vapoursynth-tools-${_plug}-git
+pkgver=r2.132d838
+pkgrel=1
+pkgdesc="Tools for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url="https://github.com/OrangeChannel/${_plug}"
+license=('GPL')
+depends=('vapoursynth-plugin-acsuite-git'
+ 'mkvtoolnix'
+ )
+makedepends=('git')
+provides=("vapoursynth-tools-${_plug}")
+conflicts=("vapoursynth-tools-${_plug}")
+source=("${_plug}::git+https://github.com/OrangeChannel/${_plug}.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 ocsuite.py "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
+ install -Dm644 tests.py "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/tests.py"
+}