summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2017-07-03 22:58:46 +0200
committerUffe Jakobsen2017-07-03 22:58:46 +0200
commitc8dac1b519b17c4d4d8aeba04d0b89daa63af718 (patch)
tree3a2a13643e6abc82d6136dbf87b08c9445deedbb
parent87b9bedd7ce777c2f2d01874d076d8479d110fd5 (diff)
downloadaur-c8dac1b519b17c4d4d8aeba04d0b89daa63af718.tar.gz
Update to 1.8
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rw-r--r--patch-cpus_test_cpu.c.patch11
3 files changed, 34 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e47a7448534..c443824a0bce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Mon Jan 9 00:16:05 UTC 2017
+# Mon Jul 3 20:51:33 UTC 2017
pkgbase = vasm
pkgdesc = Portable and retargetable 6502 6800 arm c16x jagrisc m68k ppc test tr3200 vidcore x86 z80 assembler.
- pkgver = 1.7g
+ pkgver = 1.8
pkgrel = 1
url = http://sun.hasenbraten.de/vasm/
arch = i686
arch = x86_64
license = custom
- source = http://server.owl.de/~frank/tags/vasm1_7g.tar.gz
- md5sums = 53e32b357e7356b94e7cc4378320c8ab
+ source = http://server.owl.de/~frank/tags/vasm1_8.tar.gz
+ source = patch-cpus_test_cpu.c.patch
+ md5sums = 8ac42c171c84d1460119f28cca601467
+ md5sums = 46a0705ebc82b4290dc73acdcc53fc73
pkgname = vasm
diff --git a/PKGBUILD b/PKGBUILD
index e477d8f1f0b7..683a00587df8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,34 @@
#
# Maintainer: uffe Jakobsen <_uffe_-at-_uffe_-_dot_-_org>
-_pkgver="1_7g"
+_pkgver="1_8"
pkgname=vasm
-pkgver=1.7g
+pkgver=1.8
pkgrel=1
pkgdesc="Portable and retargetable 6502 6800 arm c16x jagrisc m68k ppc test tr3200 vidcore x86 z80 assembler."
arch=('i686' 'x86_64')
url="http://sun.hasenbraten.de/vasm/"
license=('custom')
depends=()
-source=(http://server.owl.de/~frank/tags/${pkgname}${_pkgver}.tar.gz)
-md5sums=('53e32b357e7356b94e7cc4378320c8ab')
+source=(http://server.owl.de/~frank/tags/${pkgname}${_pkgver}.tar.gz
+ patch-cpus_test_cpu.c.patch)
+md5sums=('8ac42c171c84d1460119f28cca601467'
+ '46a0705ebc82b4290dc73acdcc53fc73')
+
CPU_LIST="6502 6800 arm c16x jagrisc m68k ppc test tr3200 vidcore x86 z80"
SYNTAX_LIST="std madmac mot oldstyle" # test
OUTPUT_LIST="aout bin elf hunk test tos vobj"
-build() {
+prepare()
+{
+ cd ${srcdir}/${pkgname}
+ patch -p0 -i "${srcdir}/patch-cpus_test_cpu.c.patch"
+}
+
+build()
+{
cd ${srcdir}/${pkgname}
#make doc/vasm.pdf
#make doc/vasm.html
@@ -31,7 +41,8 @@ build() {
done
}
-package() {
+package()
+{
cd ${srcdir}/${pkgname}
mkdir -p ${pkgdir}/usr/bin
for CPU in ${CPU_LIST}; do
diff --git a/patch-cpus_test_cpu.c.patch b/patch-cpus_test_cpu.c.patch
new file mode 100644
index 000000000000..91272904f31d
--- /dev/null
+++ b/patch-cpus_test_cpu.c.patch
@@ -0,0 +1,11 @@
+--- cpus/test/cpu.c.orig 2017-07-03 22:42:42.091904513 +0200
++++ cpus/test/cpu.c 2017-07-03 22:46:05.875845459 +0200
+@@ -188,7 +188,7 @@
+ size_t size=instruction_size(p,sec,pc);
+ dblock *db=new_dblock();
+ int c=opt_inst(p,sec,pc);
+- char *d;
++ unsigned char *d;
+ taddr val;
+ db->size=size;
+ d=db->data=mymalloc(size);