summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNing Sun2021-07-03 19:03:20 +0800
committerNing Sun2021-07-03 19:03:20 +0800
commit70793dbb28634c1ddbbfdd2d6cf1b8cc7a21f772 (patch)
treef1318ba4e5b2f6c1529a666c895dab2c6e3a6bf5
parentaedf2b315ee68d6309bed87eed84ec8c266ff92f (diff)
downloadaur-70793dbb28634c1ddbbfdd2d6cf1b8cc7a21f772.tar.gz
refactor vassal build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
-rw-r--r--vassal.desktop7
-rw-r--r--vassal.sh7
4 files changed, 29 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dd02b80befe..9209991883b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vassal
pkgdesc = Game engine for building and playing online adaptations of board games and card games.
pkgver = 3.5.8
- pkgrel = 1
+ pkgrel = 2
url = http://www.vassalengine.org/
arch = i686
arch = x86_64
@@ -9,7 +9,11 @@ pkgbase = vassal
depends = java-runtime>=11
source = https://github.com/vassalengine/vassal/releases/download/3.5.8/VASSAL-3.5.8-linux.tar.bz2
source = VASSAL-256x256.png
+ source = vassal.sh
+ source = vassal.desktop
md5sums = bfe7fa525c7a53f3ac041daeeb2727d0
md5sums = 4a4ec11bdbd7dbbf56e6f1d533f69a7e
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = vassal
diff --git a/PKGBUILD b/PKGBUILD
index ede312ba4a9b..8b73859f394a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,21 @@
# Contributor: David Vilar <davvil@gmail.com>
pkgname=vassal
pkgver=3.5.8
-pkgrel=1
+pkgrel=2
pkgdesc="Game engine for building and playing online adaptations of board games and card games."
arch=('i686' 'x86_64')
url="http://www.vassalengine.org/"
license=('LGPL')
depends=('java-runtime>=11')
source=(https://github.com/vassalengine/vassal/releases/download/${pkgver}/VASSAL-${pkgver}-linux.tar.bz2
- VASSAL-256x256.png)
+ VASSAL-256x256.png
+ vassal.sh
+ vassal.desktop)
noextract=()
md5sums=('bfe7fa525c7a53f3ac041daeeb2727d0'
- '4a4ec11bdbd7dbbf56e6f1d533f69a7e')
+ '4a4ec11bdbd7dbbf56e6f1d533f69a7e'
+ 'SKIP'
+ 'SKIP')
build() {
true
}
@@ -22,45 +26,19 @@ package() {
destdir=$pkgdir/usr/share/java/$pkgname
mkdir -p $destdir
-
+
cp -r doc lib $destdir
mkdir -p $pkgdir/usr/bin
- cat << EOF > $pkgdir/usr/bin/vassal
-#!/bin/bash
-
-shopt -s nullglob
-
-JAVA_BIN="\$(which java)"
-JAVA_VER="\$("\${JAVA_BIN}" -version 2>&1 | awk -F '"' '/version/ {print \$2}')"
-
-# Cut after first dot (if it's a 1.x version it's too old anyways)
-JAVA_VER="\${JAVA_VER%%.*}"
-
-# If the default java installation is not suitable
-if [[ "\${JAVA_VER}" < "11" ]]; then
- JAVA_BINS=(/usr/lib/jvm/java-{11..15}-*/bin/java)
- JAVA_BIN="\${JAVA_BINS[0]}"
-fi
-
-cd /usr/share/java/$pkgname && "\${JAVA_BIN}" -classpath lib/Vengine.jar VASSAL.launch.ModuleManager "\$@"
-EOF
+ install -Dm755 ${srcdir}/vassal.sh $pkgdir/usr/bin/vassal
chmod a+x $pkgdir/usr/bin/vassal
mkdir -p $destdir/images
cp $srcdir/VASSAL-256x256.png $destdir/images
mkdir -p $pkgdir/usr/share/applications
- cat << EOF > $pkgdir/usr/share/applications/vassal.desktop
-[Desktop Entry]
-Comment=${pkgdesc}
-Terminal=false
-Name=Vassal
-Exec=/usr/bin/vassal
-Type=Application
-Icon=/usr/share/java/${pkgname}/images/VASSAL-256x256.png
-EOF
+ install -Dm644 ${srcdir}/vassal.desktop $pkgdir/usr/share/applications/vassal.desktop
}
# vim:set ts=2 sw=2 et:
diff --git a/vassal.desktop b/vassal.desktop
new file mode 100644
index 000000000000..ecb9cafcb5bc
--- /dev/null
+++ b/vassal.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Comment=Game engine for building and playing online adaptations of board games and card games.
+Terminal=false
+Name=Vassal
+Exec=/usr/bin/vassal
+Type=Application
+Icon=/usr/share/java/vassal/images/VASSAL-256x256.png
diff --git a/vassal.sh b/vassal.sh
new file mode 100644
index 000000000000..8819f652d1dd
--- /dev/null
+++ b/vassal.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+shopt -s nullglob
+
+JAVA_BIN="$(which java)"
+
+cd /usr/share/java/vassal && "${JAVA_BIN}" -classpath lib/Vengine.jar VASSAL.launch.ModuleManager "$@"